WR1043ND + GALA TV

Pats nenaudoju, bet teko konfigūruoti pažįstamam. Jei kam reiks – konfigas žemiau.

Beje, konfigas darytas ne mano – bendradarbio Arūno. Bet veikia. Sprendimas tiems, pas ką routeriukas su Atheros čipu, ne Broadcom’u – taigi, DD-WRT VLAN sprendimas nepagelbės.

Pora niuansų su tuo TP-Link WR1043ND:

  • DD-WRT, Tomato ir pan. neveiks (arba nemokės tvarkytis su VLAN’ais)
  • reikalingas OpenWRT. Šiuo metu veikianti versija – RC5. RC6 nenaudoti.
  • Bevielis greičiausiai neveiks su RC5 – kompilinat naujausią versiją, arba laukiat pakol išleis RC7 (arba galutinę versiją). Dėl bevielio dar daug nesiaiškinau – pažiūrėsiu atskirai. (UPDATE: veikia normaliai ir su RC6)
  • UPDATE 2015.12: veikia ir su paskutine oficialia OpenWRT versija. WiFi juntamai pagreitėjo, užteko konfigūracijos backup/restore ir viskas ‘nuvažiavo’ (lyg ir buvo kažkokių nesamonių su web interface – pasijungus per SSH reikėjo atnaujinti temas).

Tinklo konfigas (/etc/config/network) toks (GALA – 4 skylė):
config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'ifname' 'eth0.2'
option 'type' 'bridge'
option 'proto' 'static'
option 'ipaddr' '192.168.1.1'
option 'netmask' '255.255.255.0'

config 'interface' 'wan'
option 'ifname' 'eth0.1'
option 'proto' 'dhcp'

config 'interface' 'vlan6'
option 'ifname' 'eth0.6'
option 'proto' 'none'
option 'defaultroute' '0'
option 'peerdns' '0'

config 'interface' 'vlan5'
option 'ifname' 'eth0.5'
option 'proto' 'none'
option 'defaultroute' '0'
option 'peerdns' '0'

config 'switch'
option 'name' 'rtl8366rb'
option 'reset' '1'
option 'enable_vlan' '1'

config 'switch_vlan'
option 'device' 'rtl8366rb'
option 'vlan' '6'
option 'ports' '0t 4 5t'

config 'switch_vlan'
option 'device' 'rtl8366rb'
option 'vlan' '5'
option 'ports' '0t 5t'

config 'switch_vlan'
option 'device' 'rtl8366rb'
option 'vlan' '1'
option 'ports' '0 5t'

config 'switch_vlan'
option 'device' 'rtl8366rb'
option 'vlan' '2'
option 'ports' '1 2 3 5t'

Jei norisi per WiFi žiūrėt GALA – tai dar reik įrašyti į /etc/rc.local:

ifconfig eth0.6 10.10.99.1 up
udpxy  -p 4022 -m 10.10.99.1 -B 4Kb -c 10
exit 0

Taip pat, pasikoreguoti firewall pagal poreikius. Atrodo viskas.

Loading Facebook Comments ...

19 thoughts on “WR1043ND + GALA TV

  1. ricardas

    sveiki, noreciau pasiteirauti, gal kas turetumete gera veikianti gala televizijos play lista, jei kas turite, ir galetumete man padeti, susisiekite su manimi skype ricisdo arba el paštu ricisdo@gmail.com

  2. ABL Post author

    Aš neturiu (net ir nenaudoju to įrenginio). Bet omnitel news’uose ne kartą buvo papostintas, o ir šiaip google gi gelbsti ;-)

  3. Zygis

    O jei noriu paleisti Gala per visus ruoterio portus, o ne tik per 4. Ar imanomas toks dalykas.

  4. ABL Post author

    Šiaip tai – pasileidi openwrt ir testuojiesi. Jei jau klausiama “ką manau” – tai manau kad veiks, bet kadangi tokio aparato neturiu ir nenaudoju – tai mano nuomonė taip ir liks tik nuomone be argumentų ;-)

  5. vds

    pasiemiau wr740 piguji routeriuka, su mintim, kad išeis padaryti tą pati… dėja… kažkaip sumaišyti portai, neina atskirti man jų… gal kas padėti gali?

  6. rytis

    Sveiki.

    Konfiguravau network failą pagal nurodytą pavyzdį, privėliau klaidų ir po to kai perkroviau maršrutizatorių nebegaliu prie jo prisijungt nei naudojant naršyklę, nei ssh, telnet klientais. Į ping’ą neatsako, nes neva tokiu (192.168.1.1) adresu nieko negalima pasiekti. Konfiguruojant tikrai nenurodziau kitokio adreso. Kas galėjo įvykti? Kaip butų galima prisijungti prie maršrutizatoriaus ir ištaisyt klaidas?

  7. Modis

    Sveiki,
    Gal galit pasakyt ką padariau ne taip, kad žiūrint tv per vlc bevieliu ryšiu, vaizdas ima strigti, perjungus kanalus next/previous keliom minutėm susitvarko, po to vėl pradeda strigti. Su speed.zebra žiūrėjau, tai greitis panašus, ar vlc įjungtas ar ne, apie 4-5 MB/s laikosi.
    Aš neesu stiprus ant šitų reikalų, teko pavargti kad wan portas veiktų po Openwrt įrašymo, tai prašom jei kam padėsiu http://nearlydeaf.com/?p=1109

  8. Tomas

    Sveiki, nepavyksta paleisti udpxy ant Netgear WNDR3700 routerio su OpenWRT. Internetas ir IPTV į STB per portus veikia puikiai, tačiau priskyrus VLAN 6 IP ir bandant žiūrėti per LAN su udpxy, nieks nevyksta. Log’e tokia klaida:

    udpxy[20506]: read_buf: read: Resource temporarily unavailable

    Firewall įvesti standartiniai nustatymai:

    config ‘rule’
    option ‘src’ ‘wan’
    option ‘proto’ ‘igmp’
    option ‘target’ ‘ACCEPT’
    option ‘_name’ ‘igmp’

    config ‘rule’
    option ‘src’ ‘wan’
    option ‘proto’ ‘udp’
    option ‘dest_ip’ ‘224.0.0.0/4’
    option ‘target’ ‘ACCEPT’
    option ‘_name’ ‘igmp_udp’

    Gal kas galėtų pasidalinti veikiančiais config? Kas galėtų būti ne taip?

  9. Mantas

    Veikia dabar kam nors Galas per WiFi? Tik šiandien pasikūriau WR1043ND. Viskas gerai. Bet norėtusi išbandyti per WiFi. Tai va, kiek “kodinau”, vlc nieko nerodo ir nerodo :) Firewall nieko nekeičiau.

  10. klaudija

    MMM per neapsiziurejima paplytinau 1.10 versijos wr1043nd.
    kokia versija su sio konfigu veikia 100%

  11. Justas

    Sveiki, gal kas yra pasikonfigines sita reikala su adsl2+ routeriuku? Ir gali pasiuliti koki routeri isigyti nes net neisivaizduoju, galvoju apie stai si TL-WDR3600 bet kiek suprantu jam nera dar paruosta OpenWRT. Nes manasis pirelis tiesiog zudo kai nori ka nors pazaisti pingas visada ~100+

  12. neiseina sukonfiginti

    swx. pas mane rooteris tp-linkwr940n. isirasiau openWRT, update, bet niekaip neiseina sukonfiginti. jei viska perkopijuoju kas parasyta tai poto tik hard resset tepadeda.
    configinu su PUTTY.exe pls help..
    rooterio orginalus configas:
    config interface loopback
    option ifname lo
    option proto static
    option ipaddr 127.0.0.1
    option netmask 255.0.0.0

    config interface lan
    option ifname eth0
    option type bridge
    option proto static
    option ipaddr 192.168.1.1
    option netmask 255.255.255.0

    config interface wan
    option ifname eth1
    option proto dhcp

    config switch eth0
    option enable_vlan 1

    config switch_vlan
    option device eth0
    option vlan 1
    oprion ports “0 1 2 3 4”

  13. Darius

    Ponios ir ponai padėkit sukonfiguruoti Mikrotik, kad veiktų Gala per PC ir WiFi. Niekur nieko nerandu :( Gal girdėjote ką kur nors? Su OpenWRT viskas ok. Bet jos nėra sukurta RB951 modeliams.

  14. Kęstas

    Sveikas,

    Vakar kaip tik pabandžiau sukišti OpenWrt 15.05 į TP-Link 1043ND ir perkonfiguruoti /etc/config/network pagal čia užrašytą config’ą. Pakoregavau ir rc.local, bet be interneto neveikia nei 4 portas, nei UDP paketai su IPTV klientu. Gal būtų galimas komentaras kaip teisingai viskas turėtų atrodyti?

  15. ABL Post author

    Sunku pasakyti, nes prieš pora mėnesių atnaujinau vieno pažįstamo dėžutę. Copy-paste konfigą ir viskas nuėjo, tai kaip ir “teisingai”.
    Gal ten kas įjungta, gal ten kas išjungta, reik žiūrėt – galima patikrint logus, pasnifinti srautus…

  16. خرید اپل ای دی

    Aw, this was an exceptionally nice post. Spending some time and actual effort to
    make a good article… but what can I say… I procrastinate a lot and never seem to
    get nearly anything done.

Leave a Reply

Your email address will not be published. Required fields are marked *